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1 Introduction 

NetSim satellite library models end-to-end, full stack, packet level communication between 

terrestrial nodes and Geostationary satellites. Geo satellites have the unique property of 

remaining permanently fixed in exactly the same position in the sky as viewed from any fixed 

location on Earth. This means ground-based antennas do not need to track them but can 

remain fixed in one direction. These satellites have orbital period that is the same as Earth’s 

rotation period and are the most common type of communications satellites. 

The Satellite MAC layer protocol supported in NetSim is TDMA for forward link and MF-TDMA 

for return link (based on the DVB S2 standards). The forward link is in the Ku band (12 – 18 

GHz) while the return link is in the Ka band (26 – 40 GHz) 

The satellite can be thought of as a relay station. It operates on the bent-pipe (transparent 

star) principle, sending back to Earth what comes in, with only amplification and a shift from 

uplink to downlink frequency.  

In NetSim, the satellite communication network library interfaces with Internetworks library. 

This means users can connect Satellite gateway and User Terminals to devices such as 

Routers, Switches Wired nodes, Access point and Wireless nodes etc. 

 
Figure 1-1: NetSim GUI showing Satellite User Terminals connected to a server via satellite links. 
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Figure 1-2: The Result dashboard and Plot window shown in NetSim after completion of simulation 

The PHY layer models include: 

a. Channel model: Friis free space path loss with Markov Loo fading model. 

b. Modulation: QPSK, 8PSK, 16APSK, 16QAM, 32APSK with appropriate coding rates. 

c. Tx, Rx Antenna gains. 

d. Antenna gain to noise temperature. 

All the choices of transport protocols, and all types of applications in unicast mode can be run.  

NetSim’s protocol source C code shipped along with (standard / pro versions) is modular and 

customizable to help researchers to design and test their own sat-com protocols. 
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2 Simulation GUI 

Open NetSim, Go to New Simulation → Satellite Comm. Networks 

 
Figure 2-1: NetSim Home Screen 

2.1 Create Scenario 

Satellite Communication Networks palette features various devices like Wired Nodes, L2 

Switch, Access Point, Wireless node, UT Router (User Terminal Router), Router, UT Node 

(User Terminal Node), Satellite Gateway, and Satellite. 

2.2 Devices specific to NetSim Satellite Comm. Library 

a. UT - User Terminal. The user terminals are part of the same communication network as 

the Satellite Gateway. The User Terminals in NetSim are UT Node and UT Router 

b. UT Router - User Terminal Router. A UT Router is used when a separate communication 

network is required. The typical use case is where there are multiple devices 

downstream who seek to utilize the sat-com link. The UT Router cannot be a source of 

any traffic. 

c. Satellite Gateway: Each gateway has two interfaces, a satellite interface and multiple 

wired interfaces. The satellite interface connects via the forward link to the satellite. The 

wired interface allows for connection to routers via the wired interface. When connected 

to a satellite, the user terminals mapped to the gateway are part of the same network. 

Multiple gateways can be configured per satellite, and round-robin scheduling is run (at 

the Network control center (NCC) which is not displayed in NetSim GUI) 
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d. Satellite: Since the satellite model is a bent pipe and satellite does not have an IP. 

NetSim supports single satellite communication, and it  can be connected to multiple 

gateways and to multiple user terminals. The satellite node cannot be the source of any 

traffic.  The default altitude of the Satellite is 35,768,000 meters, which represents the 

circular geosynchronous orbit. 

e. Coordinate System: NetSim uses a Geodetic co-ordinate system. The altitude is from 

Mean Seal level. The geocentric co-ordinate system uses distance from the centre of 

the earth. 

 
Figure 2-2: The devices present in the ribbon in NetSim’s GUI 

2.3 Placement of devices on the grid environment 

a. Add a User Terminal (UT) – Click the User Terminal > UT Node icon on the toolbar and 

place the device in the grid. UT Node must be connected to Satellite. 

b. Add a UT Router – Click the User Terminal > UT Router icon on the toolbar and place 

the device in the grid. UT Router must be connected to a Node or to a L2 Switch or to a 

Router or to an Access_Point or Satellite. 

c. Add a Satellite – Click the Satellite icon on the toolbar and place the Satellite in the grid. 

Satellite must be connected to a Satellite Gateway or to a UT Node or to a UT Router. 

d. Add a Satellite Gateway – Click the Satellite Gateway icon on the toolbar and place the 

Satellite Gateway in the grid. Satellite Gateway must be connected to a Satellite or to a 

Router. 

e. Add a Router – Click the Router icon on the toolbar and place the Router in the grid. 

f. Add a Wired Node – Click the Wired Node icon on the toolbar and place the device in 

the grid. 

g. Add a L2 Switch – Click the L2 Switch icon on the toolbar and place the device in the 

grid. 

h. Add an Access Point – Click the Access Point icon on the toolbar and place the Access 

Point in the grid. 

i. Add a Wireless Node – Click the Wireless Node icon on the toolbar and place the device 

in the grid. 
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2.4 Enable Packet Trace, Event Trace (Optional) 

Click Packet Trace / Event Trace icon in the Configure Reports option and check Enable 

Packet Trace / Event Trace check box. For detailed help about the packet and event trace, 

please refer to sections 8.4 and 8.5 in the User Manual. 

 

Figure 2-3: Enable Packet Trace, Event Trace & Plots options on top ribbon 

2.5 Enable protocol specific logs and plots 

NetSim provides protocol-specific logs for Satellite libraries, which users can enable before 

running a simulation. These can be enabled by clicking on configure reports in top ribbon > 

clicking on plots > choosing as desired, and running the simulation. 

 

Figure 2-4: Enabling the Network logs in Satellite network 

Similarly, users can enable the plots for Satellite Radio Measurements. 
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Figure 2-5: Enabling the Plots in Satellite 

2.6 GUI Configuration Parameters 

The SATELLITE parameters can be accessed by right clicking on a Satellite, Satellite 

Gateway, UT Router or UT and selecting Interface (SATELLITE) Properties → Datalink and 

Physical Layers. 

Satellite Properties 

Interface (Satellite) – Physical Layer 

Parameter Type Range Description 

G/T (dBk) Local 0-100000dBk 

Antenna gain-to-noise-
temperature is (G/T) where G is 
the antenna gain in decibels at 
the receive frequency, and T is 
the equivalent noise temperature 
of the receiving system in kelvins. 

Tx Power Local 
-10000dBW to 
10000dBW 

It is the signal intensity of the 
transmitter. The higher the power 
radiated by the transmitter's 
antenna the greater the reliability 
of the communications system. 

Access Protocol 

Fixed TDMA 

TDMA allows a number of clients 
to access a single radio-
frequency channel without 
interference by allocating unique 
time slots to each user within 
each channel, reducing the loss 
of packets and improving the 
data rate thereby delivering QoS 
to the clients. 

Fixed MF-TDMA 

Multi-frequency time-division 
multiple access is a technology 
for dynamically sharing 
bandwidth resources in an over-
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the-air two-way communications 
network. 

Base Frequency (GHz) Local 

Ku-band: 12-
18GHz 
 
Ka-band: 26-
40GHz 

The “band” in use refers to the 
radio frequencies used to and 
from the satellite: 
 
Ku-band services uses the 12 - 
18 GHz, and 
 
Ka-band services uses the 26- 40 
GHz segment of the 
electromagnetic spectrum 

Band 

Fixed KU 

Microwave frequency band used 
for satellite communication and 
broadcasting, using frequencies 
in the range of 12 -18 GHz 

Fixed KA 

Microwave frequency band used 
for satellite communication and 
broadcasting, using frequencies 
in the range of 26 - 40 GHz 

Rolloff Factor Local 0-1 

In NetSim,  
Symbol Rate = BW / (1+Roll of 
factor) and  
 
Bit Rate = Symbol rate * 
Modulation order * CodeRate 

Spacing Factor Local 0-1 

In NetSim EffectiveBandwidth 
(Hz) = AllocatedBandwidth (Hz) / 
((RollOffFactor + 1.0) * 
(SpacingFactor + 1.0));   
Spacing factor should be in the 
range of [0,1] 

Carrier Bandwidth (Hz) Local 0-1000000 Hz Bandwidth of the carrier in Hz 

Framecount in Superframe Local 0-1000000 
Number of frames present in a 
superframe. 

Frame Bandwidth (Hz) Local 0-1000000 Hz Bandwidth of the frame in Hz. 

Frame Usage Mode Local 
NORMAL 
SHORT 

Baseband frame usage modes. 

Modulation Local 

QPSK 
8PSK 
16APSK 
16QAM 
32APSK 

Modulation is the process of 
varying one waveform in relation 
to another waveform. It is used to 
transfer data over an analog 
channel. 

Coding Rate Local 
1/3,1/2, 3/5, 2/3, 
3/4, 4/5, 5/6, 8/9, 
9/10  

It states what portion of the total 
amount of information that is 
useful(non-redundant). This code 
rate typically a fractional number. 

Slot Count in Frame Local 

Short Frame: 
QPSK-90, 8PSK-
60, 
16APSK/16QAM-
45, 
32APSK-36 
Normal Frame: 
QPSK-360, 
8PSK-240, 
16APSK/16QAM-
180, 
32APSK-144 

The number of slots per frame. 
The number of slots per frame is 
based on modulation and frame 
type chosen. 
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Symbol per Slot Local 0-1000000 
The number of TDMA symbols 
within a slot, the default value of 
symbol per slot is 90. 

Pilot Block Size (Symbols) Local 
0-1000000 
symbols 

Size of pilot block in symbols 

Pilot Block Interval (Slots) Local 0-1000000 slots 
Interval (in symbols) between 
Pilot blocks 

Pilot Header (Slots) Local 0-1000000 slots 
The pilot block header size in 
slots. 

Frame Header Length 
(Bytes) 

Local 0-1000000 bytes 
Baseband frame header length in 
bytes 

BER Model Local 

Fixed 
BER value is based on the user 
input and is independent of the 
received SINR. 

FILE BASED 

File Based is a feature in NetSim 
with which users can define the 
BER. Users will have to provide a 
BER_FILE.txt file as input to 
NetSim by clicking on the Open 
file link the Physical Layer-
Properties of the device. 
 
 

MODEL BASED 

BER is computed using the 
SINR-BER formula for the 
chosen Modulation and coding. 
The pathloss and fading models 
are used in the SINR calculation.  

BER Local 0.00000001-1 

This parameter is shown is the 
Fixed option is chosen for the 
BER model parameter. Users 
can set the Bit Error Rate (BER) 
in the range shown.  

UT Properties 

Interface (Satellite) – Physical Layer 

Parameter Parameter Parameter Parameter 

Tx Antenna Gain (dB) Local 0-1000000dB 

A relative measure of an 
antenna’s ability to direct or 
concentrate radio frequency 
energy in a particular direction or 
pattern at the transmitter side. 

Rx Antenna Gain (dB) Local 0-1000000dB 

A relative measure of an 
antenna’s ability to receive radio 
frequency energy in a particular 
direction or pattern at the 
receiver side. 

Table 2-1: Satellite, Satellite Gateway, UT Router or UT and selecting Interface (SATELLITE) 
Properties → Physical Layers Description 

Propagation Model 

Link Properties 

Parameter Type Range Description 

Propagation Medium Link Air 
Medium of propagation in NetSim 
would be Air for RF waves. 

Channel Characteristics Fixed 
Pathloss and 
Fading and 
Shadowing 

Path loss and fading and 
shadowing:  In pathloss models, 
for a fixed distance between 
source and destination, path loss 
is same. We get varied path loss 



 Ver 14.4 

 

© TETCOS LLP. All rights reserved   Page 12 of 36 

for some distance between 
source and destination in 
shadowing and fading is variation 
of the attenuation of a signal with 
various variables. These 
variables include time, 
geographical position, and radio 
frequency. 

Shadowing Model Fixed NONE  

Pathloss Model Link Friis Free Space 

It Used to model the LOS path 
loss incurred in the channel. the 
Friis Free space model is 
restricted to unobstructed clear 
path between the transmitter and 
the receiver. 

Pathloss Exponent (η) Fixed 2 

Path loss exponent indicates the 
rate at which the path loss 
increases with distance. The 
value depends on the specific 
propagation environment.  

Fading Model Fixed Markov Loo 

Each state of the three-state 
Markov channel models obeys 
the Loo distribution with different 
parameters; while the state 
transition is modeled as a first-
order Markov random process. 

Direct Signal Mean (dB) Link -∞ to ∞ 
Mean value of the direct signal, 
value can be differentiated 
according to the state. 

Direct Signal Standard Dev 
(dB) 

Link 0 to ∞ 
Standard Deviation of the direct 
signal value can be differentiated 
according to the state. 

RMS Multipath Power (dB) Link -∞ to ∞ 
RMS squared multipath power in 
dB 
 

Number of Direct Signal 
Oscillators 

Link 0 to ∞ 

Number of direct signal oscillator 
is used for frequency conversion 
process in superheterodyne 
receiver. 

Number of Multipath 
Oscillators 

Link 0 to ∞ 
Number of multipath oscillators is 
used to generate higher 
oscillation frequencies. 

Direct Signal Doppler (Hz) Link 0 to ∞  

Multipath Doppler (Hz) Link 0 to ∞ 

The normalized PSD (its integral 
in the whole frequency range 
equals to one) constitutes the 
PDF for the Doppler frequencies, 
arising from the different angles 
of arrival the multipath 
components have with respect to 
the receiver’s motion. 

Initial Probability Link 0 to 1 

An initial probability distribution, 
defined on S, specifies the 
starting state. Usually this is done 
by specifying a particular state as 
the starting state. 

Table 2-2: Propagation Model/Wireless Link Properties Description 
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2.6.1 Mapping of User Terminal (UT Node / UT Router) to Satellite Gateway 

Each satellite can be connected to multiple Satellite Gateways and to Multiple User Terminals. 

The following screen shot shows how to map the User Terminal to Satellite Gateway as shown 

Figure 2-6. 

 

Figure 2-6: Mapping of User Terminal (UT Note / UT Router) to Satellite Gateway 

In order to Map User Terminal (UT Node / UT Router) to Satellite Gateway right click go to the 

properties of UT Node/UT Router → INTERFACE1 (SATELLITE) →  DATALINK LAYER → 

Gateway user can map the Satellite Gateway with UT Node / UT Router accordingly. 

Additionally, in the UT Router/UT Node -> Interface Satellite the default gateway IP should be 

set as the IP of the connected Satellite Gateway. 

Incorrect mapping of the Satellite Gateway and/or the default Gateway IP address, in the 

properties of the UT Node / UT Router could lead application crash or NIL application 

throughputs. 
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2.6.2 Configuring Static Routes 

After mapping the UT Router/UT Node to a Satellite Gateway, static routes need to be 

configured in the devices to forward traffic. Let us consider the following network scenario as 

shown Figure 2-7. 

 
Figure 2-7: Network Topology in this experiment 

In this network scenario, for UDP traffic to be sent from UT Node 3 to UT Node 4, static routes 

need to be set in UT Node 3 and in the Satellite Gateway 2. 

If TCP traffic needs to be sent from UT Node 3 to UT Node 4, then static routes need to be set 

in UT Node 4 as well. This is essential for connection establishment and sending 

acknowledgements. 

Refer the featured example on Configuring applications from UT Node to UT Node for detailed 

information on static route configuration. 
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3 Model Features 

3.1 TDMA Forward Link and MF TDMA Return Link 

 
Figure 3-1: Forward and Return links. The Network Control Centre (NCC) is not displayed in NetSim 

and is assumed to be part of every satellite  

In NetSim, a Forward link is defined as the direction from Satellite Gateway to Satellite to UT 

Node / UT Router. A Return link is defined as the direction from the UT Node / UT Router to 

Satellite to the Satellite Gateway. 

The protocol operating in the Forward link is Time Division Multiple Access (TDMA). The 

protocol operating in the Return link is Multi Frequency Time Devision Multiple Access (MF-

TDMA). 

Both the Forward link and Return link transmissions in NetSim are modeled as Layer-2 

transmissions. The framing is as explained in the subsequent paragraph.  

Each Super Frame is composed of a number of Frames. This is taken as a user input, given 

by the attribute Framecount in SuperFrame available in Satellite -> Interface Satellite -> 

Physical Layer properties. The frames in turn are composed of carriers (in frequency) and slots 

(in symbols). The number of carriers would be 

𝑁𝑢𝑚𝑏𝑒𝑟 𝑜𝑓 𝐶𝑎𝑟𝑟𝑖𝑒𝑟𝑠 =
𝐹𝑟𝑎𝑚𝑒 𝐵𝑎𝑛𝑑𝑤𝑖𝑑𝑡ℎ (𝐻𝑧)

𝐶𝑎𝑟𝑟𝑖𝑒𝑟 𝐵𝑎𝑛𝑑𝑤𝑖𝑑𝑡ℎ (𝐻𝑧)
 

The number of slots per frame is determined by the modulation scheme chosen by the user.  
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3.2 Modulation and coding schemes supported 

1. QPSK with coding rates 1/3, 1/2,1/4, 2/5, 3/5, 2/3, 3/4, 4/5, 5/6, 8/9, 9/10 

2. 8PSK with coding rates 3/5, 2/3, 3/4, 5/6, 8/9, 9/10 

3. 16APSK with coding rates 2/3, 3/4, 4/5, 5/6, 8/9, 9/10 

4. 16QAM with coding rates 3/4, 5/6 

5. 32APSK with coding rates 3/4, 4/5, 5/6, 8/9, 9/10 

Note: 

• The modulation and coding rate are specified in Table 12 on page 32 of the ETSI EN 302 307-

1 European Standard 

3.3 Physical layer framing for forward and return links 

 
Figure 3-2: Format of a “Physical Layer Frame” PLFRAME  

 𝜼𝒍𝒅𝒑𝒄 = 𝟔𝟒𝟖𝟎𝟎  

(𝒏𝒐𝒓𝒎𝒂𝒍 𝒇𝒓𝒂𝒎𝒆) 

𝒍 = 𝟏𝟔𝟐𝟎𝟎  
(𝒔𝒉𝒐𝒓𝒕 𝒇𝒓𝒂𝒎𝒆) 

𝜼𝑴𝑶𝑫 (𝒃𝒊𝒕𝒔
/𝑯𝒛) 

𝑆 𝜂 % 𝑛𝑜
− 𝑝𝑖𝑙𝑜𝑡 

𝑆 𝜂 % 𝑛𝑜 − 𝑝𝑖𝑙𝑜𝑡 

2 360 99.72 90 98.90 

3 240 99.59 60 98.36 

4 180 99.45 45 97.83 

5 144 99.31 36 97.30 

Table 3-1: S = number of SLOTs per FRAME (number of symbols per slot is 90) 

The normal frame and short frame setting can be done using the Frame Usage Mode 

parameter in the GUI as shown Figure 3-3. 

Changing the Modulation scheme in UI would change the value of S (Slot count in frame) 
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Figure 3-3: Satellite > Physical layer properties window 

Default NetSim GUI settings 

▪ Symbols per slot: 90 

▪ Pilot Block size (symbols): 36 

▪ Pilot block interval (slots): 16 

▪ PL header size (slots): 1 

▪ Frame header size (In bytes): 10 (per ETSI EN 302 307 V1.3.1) 

▪ Frame Type: Normal (Options are normal or short) 

3.4 Satellite PHY: Data Rate  

Given below is the data rate calculation methodology for both forward and return links. The 

parameter values used are the default values in NetSim GUI. 

𝑆𝑦𝑚𝑏𝑜𝑙 𝑅𝑎𝑡𝑒 =
𝐵𝑊

(1 + (𝑅𝑜𝑙𝑙 𝑜𝑓 𝑓𝑎𝑐𝑡𝑜𝑟))
 

𝐵𝑖𝑡 𝑅𝑎𝑡𝑒 = 𝑆𝑦𝑚𝑏𝑜𝑙 𝑟𝑎𝑡𝑒 × 𝑀𝑜𝑑𝑢𝑙𝑎𝑡𝑖𝑜𝑛 𝑜𝑟𝑑𝑒𝑟 × 𝐶𝑜𝑑𝑒𝑅𝑎𝑡𝑒 

𝐵𝑎𝑛𝑑𝑤𝑖𝑑𝑡ℎ (𝐻𝑧) = 𝐹𝑟𝑎𝑚𝑒_𝐵𝑎𝑛𝑑𝑤𝑖𝑑𝑡ℎ (𝐻𝑧) = 106 𝐻𝑧  
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𝐶𝑒𝑛𝑡𝑟𝑎𝑙 𝐹𝑟𝑒𝑞𝑢𝑒𝑛𝑐𝑦 (𝐻𝑧) = 𝐵𝑎𝑠𝑒 𝐹𝑟𝑒𝑞𝑢𝑒𝑛𝑐𝑦 (𝐻𝑧) +
𝐵𝑎𝑛𝑑𝑤𝑖𝑑𝑡ℎ (𝐻𝑧)

2.0
 

𝐶𝑒𝑛𝑡𝑟𝑎𝑙 𝐹𝑟𝑒𝑞𝑢𝑒𝑛𝑐𝑦 (𝐻𝑧) = 26 × 109 + 
106

2
= 2.60005 × 1010𝐻𝑧 

𝐸𝑓𝑓𝑒𝑐𝑡𝑖𝑣𝑒 𝐵𝑎𝑛𝑑𝑤𝑖𝑑𝑡ℎ (𝐻𝑧) =
 𝐶𝑎𝑟𝑟𝑖𝑒𝑟 𝐵𝑎𝑛𝑑𝑤𝑖𝑑𝑡ℎ (𝐻𝑧)

(𝑅𝑜𝑙𝑙𝑂𝑓𝐹𝑎𝑐𝑡𝑜𝑟 + 1.0) × (𝑆𝑝𝑎𝑐𝑖𝑛𝑔𝐹𝑎𝑐𝑡𝑜𝑟 + 1.0)
 

𝐸𝑓𝑓𝑒𝑐𝑡𝑖𝑣𝑒 𝐵𝑎𝑛𝑑𝑤𝑖𝑑𝑡ℎ (𝐻𝑧) =
106

(1.0 + 1.0) × (1.0 + 1.0)
= 25 × 104 𝐻𝑧 

𝑆𝑦𝑚𝑏𝑜𝑙 𝑅𝑎𝑡𝑒 = 𝐸𝑓𝑓𝑒𝑐𝑡𝑖𝑣𝑒 𝐵𝑎𝑛𝑑𝑤𝑖𝑑𝑡ℎ (𝐻𝑧) = 25 × 104𝐻𝑧 

𝑀𝑜𝑑𝑢𝑙𝑎𝑡𝑖𝑜𝑛 𝐵𝑖𝑡𝑠 = 2 

The number of Modulation Bits depends on the modulation scheme per the table below: 

Modulation  Modulation bits 

QPSK 2 

8PSK 3 

16APSK/16QAM 4 

32APSK 5 

Table 3-2: Modulation bits for different modulation 

𝑆𝑙𝑜𝑡𝑠 = 𝑆𝑙𝑜𝑡 𝐶𝑜𝑢𝑛𝑡 𝑖𝑛 𝐹𝑟𝑎𝑚𝑒 + 𝑃𝑖𝑙𝑜𝑡 𝐻𝑒𝑎𝑑𝑒𝑟 (𝑠𝑙𝑜𝑡𝑠) = 360 + 1 = 361 

𝐷𝑎𝑡𝑎 𝑆𝑦𝑚𝑏𝑜𝑙𝑠 = 𝑆𝑙𝑜𝑡𝑠 × 𝑆𝑦𝑚𝑏𝑜𝑙 𝑝𝑒𝑟 𝑆𝑙𝑜𝑡 = 361 × 90 = 32490 

𝑃𝑖𝑙𝑜𝑡 𝑆𝑙𝑜𝑡 =
𝑆𝑙𝑜𝑡𝑠

𝑃𝑖𝑙𝑜𝑡 𝐵𝑙𝑜𝑐𝑘 𝐼𝑛𝑡𝑒𝑟𝑣𝑎𝑙
=

361

16
= 22 

𝑃𝑖𝑙𝑜𝑡 𝑆𝑦𝑚𝑏𝑜𝑙 = 𝑃𝑖𝑙𝑜𝑡 𝑆𝑙𝑜𝑡 × 𝑃𝑖𝑙𝑜𝑡 𝑏𝑙𝑜𝑐𝑘 𝑆𝑖𝑧𝑒 (𝑠𝑦𝑚𝑏𝑜𝑙𝑠) = 22 × 36 = 792 𝑆𝑦𝑚𝑏𝑜𝑙𝑠 

𝑇𝑜𝑡𝑎𝑙 𝑆𝑦𝑚𝑏𝑜𝑙 = 𝑃𝑖𝑙𝑜𝑡 𝑆𝑦𝑚𝑏𝑜𝑙 + 𝐷𝑎𝑡𝑎 𝑆𝑦𝑚𝑏𝑜𝑙𝑠 = 792 + 32490 = 33282 

𝐹𝑟𝑎𝑚𝑒 𝑙𝑒𝑛𝑔𝑡ℎ =
𝑇𝑜𝑡𝑎𝑙 𝑆𝑦𝑚𝑏𝑜𝑙

𝑆𝑦𝑚𝑏𝑜𝑙 𝑅𝑎𝑡𝑒
× 1000000 =

33282

250000
× 1000000 = 133128 𝜇𝑠 

𝑃𝑖𝑙𝑜𝑡 𝐵𝑙𝑜𝑐𝑘 𝐿𝑒𝑛𝑔𝑡ℎ =
𝑃𝑖𝑙𝑜𝑡 𝑏𝑙𝑜𝑐𝑘 𝑆𝑖𝑧𝑒 

𝑆𝑦𝑚𝑏𝑜𝑙 𝑅𝑎𝑡𝑒
× 1000000 =

36

250000
× 1000000 = 144 𝜇𝑠 

𝑆𝑙𝑜𝑡 𝐿𝑒𝑛𝑔𝑡ℎ =
𝑆𝑦𝑚𝑏𝑜𝑙 𝑝𝑒𝑟 𝑆𝑙𝑜𝑡

𝑆𝑦𝑚𝑏𝑜𝑙 𝑅𝑎𝑡𝑒
× 1000000 =

90

250000
× 1000000 = 360 𝜇𝑠 
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𝑆𝑢𝑝𝑒𝑟𝐹𝑟𝑎𝑚𝑒 𝐷𝑢𝑟𝑎𝑡𝑖𝑜𝑛 = 𝐹𝑟𝑎𝑚𝑒 𝑙𝑒𝑛𝑔𝑡ℎ × 𝐹𝑟𝑎𝑚𝑒𝑠 𝑝𝑒𝑟 𝑆𝑢𝑝𝑒𝑟𝐹𝑟𝑎𝑚𝑒 = 133128 × 10

= 1331280 𝜇𝑠 

𝐵𝑖𝑡𝑠 𝑝𝑒𝑟 𝑆𝑙𝑜𝑡 = 𝑆𝑦𝑚𝑏𝑜𝑙 𝑝𝑒𝑟 𝑠𝑙𝑜𝑡 × 𝑀𝑜𝑑𝑢𝑙𝑎𝑡𝑖𝑜𝑛 𝐵𝑖𝑡𝑠 × 𝐶𝑜𝑑𝑖𝑛𝑔 𝑅𝑎𝑡𝑒 = 90 × 2 ×
1

2
= 90 

𝐵𝑖𝑡𝑠 𝑝𝑒𝑟 𝐹𝑟𝑎𝑚𝑒 = 𝐵𝑖𝑡𝑠 𝑝𝑒𝑟 𝑆𝑙𝑜𝑡 ×  𝑆𝑙𝑜𝑡 𝐶𝑜𝑢𝑛𝑡 𝑖𝑛 𝐹𝑟𝑎𝑚𝑒 = 90 × 360 = 32400 

𝐷𝑎𝑡𝑎 𝑅𝑎𝑡𝑒 =
𝐵𝑖𝑡𝑠 𝑝𝑒𝑟 𝑆𝑙𝑜𝑡

𝑆𝑙𝑜𝑡 𝐿𝑒𝑛𝑔𝑡ℎ
=

90 𝑏𝑖𝑡𝑠

360 𝜇𝑠
= 0.25 × 106 𝑏𝑖𝑡𝑠/𝑠𝑒𝑐 = 0.25 𝑀𝑏𝑝𝑠 

3.5 Analytical throughput estimation 

Let us an example in which the Packet Size (App layer) is 1460B which translates to 1488B at 

the PHY layer after addition of overheads, with QPSK modulation and  
1

2
 coding rate. For this 

modulation and coding rate the raw PhyRate of the channel is 162249 bps using the formulas 

given in 3.4. The analytical throughput estimate for such a scenario would be: 

𝑃𝑎𝑐𝑘𝑒𝑡𝑇𝑟𝑎𝑛𝑠𝑚𝑖𝑠𝑠𝑖𝑜𝑛𝑇𝑖𝑚𝑒 =
𝑃𝑎𝑐𝑘𝑒𝑡𝑆𝑖𝑧𝑒(𝑎𝑡 𝑃𝐻𝑌) × 8

𝑃ℎ𝑦𝑅𝑎𝑡𝑒(𝑏𝑝𝑠)
=

1488 × 8

162249
= 0.0733687𝑠 = 73368.7𝜇𝑠 

𝑃𝑎𝑐𝑘𝑒𝑡𝑠𝑃𝑒𝑟𝐹𝑟𝑎𝑚𝑒 = ⌊
𝐹𝑟𝑎𝑚𝑒𝑇𝑖𝑚𝑒

𝑃𝑎𝑐𝑘𝑒𝑡𝑇𝑟𝑎𝑛𝑠𝑚𝑖𝑠𝑠𝑖𝑜𝑛𝑇𝑖𝑚𝑒
⌋ = ⌊

133128

73368.7
⌋ = ⌊1.81⌋ = 1  

𝑃𝑎𝑐𝑘𝑒𝑡𝑠𝑃𝑒𝑟𝐹𝑟𝑎𝑚𝑒  is the number of packets that can be packed in a frame, and hence the 

greatest integer or floor function is used. 

𝐵𝑦𝑡𝑒𝑠𝑃𝑒𝑟𝐹𝑟𝑎𝑚𝑒 = 𝑃𝑎𝑐𝑘𝑒𝑡𝑠𝑃𝑒𝑟𝐹𝑟𝑎𝑚𝑒 × 𝑃𝑎𝑐𝑘𝑒𝑡𝑆𝑖𝑧𝑒(𝐵) = 1488 × 1 = 1488 

𝑁𝑢𝑚𝑏𝑒𝑟𝑂𝑓𝐹𝑟𝑎𝑚𝑒𝑠𝑃𝑒𝑟𝑆𝑒𝑐𝑜𝑛𝑑 =
1

𝐹𝑟𝑎𝑚𝑒 𝐷𝑢𝑟𝑎𝑡𝑖𝑜𝑛(𝑠)
=

1

0.133128
= 7.51 

𝑃ℎ𝑦𝑇ℎ𝑟𝑜𝑢𝑔ℎ𝑝𝑢𝑡 = 𝑁𝑢𝑚𝑏𝑒𝑟𝑂𝑓𝐹𝑟𝑎𝑚𝑒𝑠𝑃𝑒𝑟𝑆𝑒𝑐𝑜𝑛𝑑 × (𝐵𝑦𝑡𝑒𝑠𝑃𝑒𝑟𝐹𝑟𝑎𝑚𝑒 × 8)

= 7.51 × (1488 × 8) = 89399.04 𝑏𝑝𝑠 = 0.089 𝑀𝑏𝑝𝑠 

𝐴𝑝𝑝𝑙𝑖𝑐𝑎𝑡𝑖𝑜𝑛𝑇ℎ𝑟𝑜𝑢𝑔ℎ𝑝𝑢𝑡 =
1460

1488
× 𝑃ℎ𝑦𝑇ℎ𝑟𝑜𝑢𝑔ℎ𝑝𝑢𝑡 = 0.087 𝑀𝑏𝑝𝑠 
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3.6 PHY rate for various modulations and coding rates 

Modulation 
Modulation 
bits 

Slot Count in a 
frame 

Coding Rate 
PHY Rate 
(Mbps) 

QPSK 2 360 

1/3 0.167 

1/2 0.250 

1/4 0.125 

2/5 0.200 

3/5 0.300 

2/3 0.333 

3/4 0.375 

4/5 0.400 

5/6 0.417 

8/9 0.444 

9/10 0.450 

8PSK 3 240 

3/5 0.450 

2/3 0.500 

3/4 0.561 

5/6 0.625 

8/9 0.667 

9/10 0.675 

16APSK 4 180 

2/3 0.667 

3/4 0.750 

4/5 0.800 

5/6 0.833 

8/9 0.889 

9/10 0.900 

16QAM 4 180 
3/4 0.750 

5/6 0.833 

32APSK 5 144 

3/4 0.936 

4/5 1.000 

5/6 1.042 

8/9 1.111 

 9/10 1.125 

Table 3-3: List of support modulation schemes and coding rates, and their respective PHY Rates 

3.7 Satellite PHY: Land Satellite Channel Model 

3.7.1 Propagation  

The distance between the ground nodes and the satellite determines the propagation delay 

and path loss of the radio signal. The distance is computed based on the cartesian distance 

between the ground nodes and the satellite. NetSim computes the propagation delay of the 

radio signal traveling from the source node to the destination node at the speed of light. The 

propagation model calculates the weakening of the radio signal as it propagates from the 

source node per the pathloss and fading model. 

3.7.2 Pathloss Model – Friis Free Space Propagation 

The free space propagation model is used to predict received signal strength when the 

transmitter and receiver have a clear, unobstructed line-of-sight path between them. Satellite 

communication systems and microwave line-of-sight radio links typically undergo free space 
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propagation. The free space power received by a receiver antenna which is separated from a 

radiating transmitter antenna by distance d, is given by the Friis free space equation. 

 𝑃𝑟  =  𝑃𝑡 +  𝐺𝑡 +  𝐺𝑟 +  20 log10 (
𝜆

(4 ∗ 𝜋 ∗ 𝑑𝑜)
)  +  (10 × 2 × log10 (

𝑑𝑜

𝑑
)) 

 where 𝑃𝑡is the transmitted power. 

𝑃𝑟 is the received power.  

𝐺𝑡  is the transmitter antenna gain. 

𝐺𝑟  is the receiver antenna gain. 

d is the T-R separation distance in meters. 

λ is the wavelength in meters. 

3.7.3 Fading model 

NetSim uses a 3 state (state 1, state 2 and state 3) Markov model to simulate fading.  

The conditional probabilities of state 𝑠𝑛+1 given the state 𝑠𝑛are described by state transition 

probabilities 𝑝𝑖𝑗 

Where 𝑆1, 𝑆2, 𝑆3 denotes respective channel state, 𝑃𝑖𝑗 is the probability the Markov process 

goes from state i to state j.  

 
Figure 3-4: Switching of three-state Markov process 

The switching among each state is described by a transition matrix P, which is 

                                     𝑝11    𝑝12    𝑝13 

               𝑃 =           𝑝21     𝑝22    𝑝23    

                                    𝑝31    𝑝32    𝑝33  

Each state of the three-states of the Markov model obeys the Loo distribution with different 

parameters, while the state transition is modeled as a first-order Markov random process. 

The Loo distribution considers the received signal as a sum of two signal components. A log-

normally distributed direct signal expresses the slow fading component corresponding to 
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varying shadowing conditions of the direct signal. A Rice distribution characterizes the fast-

fading component due to multipath effects.  

The Loo parameter triplet consists of the mean, the standard deviation for the log-normally 

distributed direct signal, and the average multipath power.  

𝑁(𝜇, 𝜎2) + 𝑅 

Depending on the current state interval and on the environment of the terminal, a new random 

Loo parameter triplet is generated. The output of the channel model is a time-series of the 

received signal in form of a complex envelope. 

And finally, the model computes the Loo distributed time-series including Doppler shaping for 

every new state interval, which is the output of the proposed LMS channel model. 

 
Figure 3-5: The Satellite LMS channel Model 

3.7.4 SNR - BER Calculation 

𝑆𝑁𝑅 (𝑑𝐵𝑚) =  𝑙𝑜𝑔10 (
𝑅𝑒𝑐𝑒𝑖𝑣𝑒𝑑 𝑝𝑜𝑤𝑒𝑟 (𝑖𝑛 𝑚𝑊)

 𝑇ℎ𝑒𝑟𝑚𝑎𝑙 𝑁𝑜𝑖𝑠𝑒 (𝑖𝑛 𝑚𝑊)
) 

The SNR is calculated separately for each ‘hop’ of each link. This means the calculation is 

done from Gateway to Satellite and then separately again from Satellite to UT, and vice versa.  
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𝑁𝑜𝑖𝑠𝑒 = 𝑘𝐵 𝑇 𝐵 where 𝑘𝐵is the Boltzman’s constant, B is the carrier bandwidth and 𝑇 is the 

temperature calculated per user input of 
𝐺

𝑇
(𝑑𝐵𝐾) in NetSim UI.  

NetSim provides three options for BER.  

▪ Model Based:  The BER is then calculated for each link based on the SNR. Please see 

Propagation-Models.pdf document for detailed information on BER calculation.  

▪ Fixed: the BER value can be input in the GUI. If this option is chosen, the SNR (derived 

from propagation model) is not used. 

▪ File Based: SNR – BER table should be provided in a file per the format given below. 

This table should be in increasing order of SNR. The SNR is calculated by NetSim from 

the RF propagation model. For this SNR, the appropriate BER is selected from this table. 

BER is 1.0 for any SNR value below SNR1, and BER is 0.0 for any SNR greater than 

SNRn. 

SNR1, BER1 

SNR2, BER2 

… 

SNRn, BERn 

Note:  Users can enable the Satellite Propagation Log to see the SNR calculated from RF propagation 

model and then choose appropriate entries of SNR, BER values into the BER-File to see the impact on 

throughput. 

3.8 Results 

Please refer NetSim User manual section 8 for Results and Analysis. 

3.8.1 Satellite Log  

NetSim Satellite Log file records UT Satellite association, calculated superframe, frame, slot, 

bandwidth, etc., This log can be enabled/disabled by going to Plots option and 

checking/unchecking the Satellite Log option under the Network Logs section as shown below: 
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Figure 3-6: Enabling Satellite Log file. 

A log file specific to satellite communication, is generated post simulation as shown in screen 

shot below, 

 
Figure 3-7: Result Window 

On opening, the satellite log file would look like the image below. 
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Figure 3-8: NetSim Satellite communication log file 

This file logs details such as 

▪ UT – Satellite Gateway association 

▪ Calculated Super frame, frame, slot, bandwidth, carrier count etc. for each satellite. 

▪ Frame by frame transmissions with time stamps 

3.8.2 Satellite Radio Measurements Log 

NetSim Satellite Radio Measurements Log file records Tx Power, Rx power, Pathloss, fading 

Loss, Noise, SNR, etc. This log can be enabled/disabled by going to Logs option and 

checking/unchecking the Satellite Radio Measurements Log option under the Network Logs 

section as shown below: 
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Figure 3-9: Enabling Satellite Radio Measurements Log file. 

The Satellite Radio Measurements.csv file will contain the following information: 

• Time in Milliseconds 

• Transmitter Name 

• Receiver Name 

• Transmitter Power in dBm 

• Pathloss in dB 

• Shadowing Loss in dB 

• Fading Loss in dB 

• Total Loss in dB 

• Received Power in dBm 

• Noise in dBm 

• SNR in dB 

Satellite Radio Measurements log files will be available under the Logs in the results window 

as shown below: 
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Figure 3-10: Result Window 

Users can see Tx Power, Rx power, pathloss, fading-loss, Total loss, noise, and SNR values 

in the Log files for each forward and return link. 

 
Figure 3-11: Satellite Radio Measurements log file 

3.9 Omitted Features 

▪ Regenerative transponder where the signal is demodulated, decoded, re-encoded and 

modulated aboard the satellite. 

▪ Impact of Rain/Weather on signal propagation  

▪ Forward Error Coding in Layer 2 

▪ IPv6 Addressing  

▪ No support for LEO, MEO 
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4 Featured Examples 

4.1 Bandwidth variation through MCS configuration 

Open NetSim, Select Examples ->Satellite Communication -> Bandwidth variation 

through MCS configuration then click on the tile in the middle panel to load the example as 

shown in Figure 4-1. 

 
Figure 4-1: List of scenarios for the example of Bandwidth variation through MCS configuration 

The following network diagram illustrates, what the NetSim UI displays when you open the 

example configuration file as shown Figure 4-2. 

 
Figure 4-2: Network set up for studying the Bandwidth variation through MCS configuration. 
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Settings done in example config file:  

1. Set the following property as shown in the table below. To configure it, click on the satellite 

device, expand the property panel on the right side, and change the property as below. 

Satellite Properties -> Interface (Satellite) -> Physical Layer-> Forward 

BER Model Fixed 

BER 0.00000001 

Table 4-1: Satellite Properties > Interface (Satellite) > Physical Layer > Forward 

2. Click on UT Router and set the following property as shown in below given table.  

UT Router Properties -> Interface (Satellite) -> Datalink Layer 

Gateway Sat Gateway 3 

Table 4-2: UT Router Properties > Interface (Satellite) > Datalink Layer 

Note: For manually configured scenario, user need to mention the gateway name for UT 

nodes under datalink layer. 

3. Go to Router 4 properties -> Network Layer ->Enable - Static IP Route ->Click on Static 

Route IP via GUI. 

     
Figure 4-3: Router Network layer properties window 

Set the properties in Static Route IP window as per the screenshot below and click on Add. 

Click on OK. 
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Figure 4-4: Configuring Static route window for router 

4. Go to Sat Gateway 3 properties -> Network Layer ->Enable - Static IP Route ->Configure 

Static Route IP via GUI.  Set the properties in Static Route IP window as per the screenshot 

below and click on Add. Click on OK. 

 
Figure 4-5: Configuring Static route window for Sat_Gateway_3 

5. Go to UT Router 2 properties -> Network Layer -> Enable - Static IP Route -> Configure 

Static Route IP via GUI. Set the properties in Static Route IP window as per the screenshot 

below and click on Add. Click on OK. 
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Figure 4-6: Configuring Static route window for UT_Router_2 

6. Create a CBR application from set traffic tab in ribbon on the top between source id 5 to 

destination id 6 with packet size as 1460Bytes and Inter Arrival time as 467μs (Generation 

Rate=25Mbps). Transport Protocol is set to UDP. 

7. Change the Satellite Properties → Interface (Satellite) → Physical Layer → Forward → 

Modulation and respective coding rates as shown in below Table 4-3 but for return link is 

fixed Modulation-> 32APSK and Coding Rate ->3/4. 

8. Run simulation for 10 seconds and observe the result.  

Note: Satellite properties in the physical layer changes done only for the forward and Return layer properties. 

Result: Observe the application throughput as we change the modulation scheme (Satellite 

Properties → Interface (Satellite) → Physical Layer → Forward → Modulation) and respective 

coding rates (Satellite Properties → Interface (Satellite) → Physical Layer → Forward → 

Coding Rate). 

Modulation Coding Rate Throughput (Mbps) 

QPSK 
1/3 0.084 

9/10 0.336 

8PSK 
3/5 0.379 

9/10 0.504 

16APSK 
2/3 0.505 

9/10 0.675 

16QAM 
3/4 0.677 

5/6 0.677 

32APSK 
3/4 0.844 

8/9 0.846 

Table 4-3: Compare the different Modulation Scheme and Coding Rate vs. Throughput 
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4.2 Configuring applications from UT Node to UT Node 

Open NetSim, Select Examples ->Satellite Communication -> UT to UT Communication 

then click on the tile in the middle panel to load the example as shown in below screenshot 

 
Figure 4-7: List of scenarios for the example of UT to UT Communication 

The following network diagram illustrates, what the NetSim UI displays when you open the 

example configuration file as shown Figure 4-8. 

 

 
Figure 4-8: Network set up for studying the UT-to-UT Communication 

Settings done in example config file 

1. Click on UT node and expand the property panel on the right side and set the following 

property as shown in below given table: 
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UT Node Properties -> Interface (Satellite) -> DataLink Layer 

Gateway Sat Gateway 2 

Table 4-4: UT Node Properties > Interface (Satellite) > DataLink Layer 

2. Similarly, go to UT Node 3 properties -> Network Layer -> Enable - Static IP Route -

>Configure Static Route IP. 

 

Figure 4-9: Network layer properties window for UT Node 2 

3. Set the properties in Static Route IP window as per the screenshot below and click on Add. 

Click on OK. 

 

Figure 4-10: Configure static route for UT Node 2 

4. Go to Sat Gateway 2 properties -> Network Layer -> Enable - Static IP Route ->Configure 

Static Route IP via GUI. 



 Ver 14.4 

 

© TETCOS LLP. All rights reserved   Page 34 of 36 

 
Figure 4-11: Network layer properties window for Sat Gateway 2 

5. Set the properties in Static Route IP window as per the screenshot below and click on Add. 

Click on OK. 

  
Figure 4-12: Configure static route for Satellite Gateway 4 

6. Create application from set traffic tab in the ribbon on the top and set application properties 

as default (Packet Size: 1460, Inter Arrival Time: 20000 µs) 

7. Click on application and set Transport Protocol to UDP in property panel. 

8. Enable Packet Trace and Plots from the configure report tab. 

9. Run simulation for 100 seconds and observe the result.  



 Ver 14.4 

 

© TETCOS LLP. All rights reserved   Page 35 of 36 

Result: Go to the result window and open packet trace, filter the PACKET_ID to 1. There, the 

user can observe the packet flow from UT node (source) → Satellite → Sat gateway → Satellite 

→ UT node (destination)  

 
Figure 4-13: Packet Trace 
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